Cabal 2.0 требуется при использовании ночного снимка со стеком

Я пытаюсь создать новый проект с помощью nightly-2017-08-17 снимок

stack new test --resolver nightly-2017-08-17

однако это дает следующую ошибку:

Downloading template "new-template" to create project "test" in test/ ...
Looking for .cabal or package.yaml files to use to init the project.
Using cabal packages:
- test/test.cabal

Selected resolver: nightly-2017-08-17
Unable to parse cabal file: FromString "This package requires at least Cabal version 2.0" Nothing

Cabal находится в последней версии:

stack setup --upgrade-cabal
Currently installed Cabal is 2.0.0.2, newest is 2.0.0.2. I'm not upgrading Cabal.
stack will use a sandboxed GHC it installed
For more information on paths, see 'stack path' and 'stack exec env'
To use this GHC and packages outside of a project, consider using:
stack ghc, stack ghci, stack runghc, or stack exec

Это не правильный способ выбора этого ночного снимка с stack или это ошибка в программе?

1 ответов


формат файла Cabal изменился в версии 2.0 (вероятно, из-за backpack). Вы должны использовать версию стека >= 1.5.1 который обходит эту ошибку. Правильное исправление для этого, вероятно, будет выпущено в следующей версии Stack. IIRC, исправление уже находится в главном brach стека-так что обновление через --source-only willl также работает для вас.

Вы можете прочитать изменений здесь, чтобы узнать больше информации об этом.