Как использовать драгоценные камни, установленные в каталоге vendor/bundle

Я установил драгоценные камни внутри моего каталога проекта в поставщике / пакете, используя

bundle install --path vendor/bundle

все драгоценные камни правильно устанавливаются.

.bundle / config file

BUNDLE_PATH: vendor/bundle
BUNDLE_DISABLE_SHARED_GEMS: '1'

bundle env

окружающая среда

Bundler   1.10.6
Rubygems  2.4.8
Ruby      2.0.0p643 (2015-02-25 revision 49749) [x86_64-linux]
GEM_HOME  /home/xyz/.rvm/gems/ruby-2.0.0-p643
GEM_PATH  /home/xyz/.rvm/gems/ruby-2.0.0-p643:/home/xyz/.rvm/gems/[email protected]
RVM       1.26.11 (1.26.11)
Git       1.9.1
rubygems-bundler (1.4.4)

настройки Bundler

path
  Set for your local app (/home/xyz/code/project/.bundle/config): "vendor/bundle"
  Set for the current user (/home/xyz/.bundle/config): "vendor/bundle"
disable_shared_gems
  Set for your local app (/home/xyz/code/project/.bundle/config): "1"
  Set for the current user (/home/xyz/.bundle/config): "1"

Gemfile

source 'https://rubygems.org'

gem 'creek'
gem 'faraday'
gem 'faraday_middleware'
gem 'json'
gem 'logger'
gem 'mechanize'
gem 'nokogiri'
gem 'trollop'
gem 'yajl-ruby'
gem 'simplecov', :require => false, :group => :test
gem 'test-unit'

Gemfile.lock

GEM
  remote: https://rubygems.org/
  specs:
    creek (1.0.8)
      nokogiri (~> 1.6.0)
      rubyzip (>= 1.0.0)
    docile (1.1.5)
    domain_name (0.5.24)
      unf (>= 0.0.5, < 1.0.0)
    faraday (0.9.1)
      multipart-post (>= 1.2, < 3)
    faraday_middleware (0.10.0)
      faraday (>= 0.7.4, < 0.10)
    http-cookie (1.0.2)
      domain_name (~> 0.5)
    json (1.8.3)
    logger (1.2.8)
    mechanize (2.7.3)
      domain_name (~> 0.5, >= 0.5.1)
      http-cookie (~> 1.0)
      mime-types (~> 2.0)
      net-http-digest_auth (~> 1.1, >= 1.1.1)
      net-http-persistent (~> 2.5, >= 2.5.2)
      nokogiri (~> 1.4)
      ntlm-http (~> 0.1, >= 0.1.1)
      webrobots (>= 0.0.9, < 0.2)
    mime-types (2.6.1)
    mini_portile (0.6.2)
    multipart-post (2.0.0)
    net-http-digest_auth (1.4)
    net-http-persistent (2.9.4)
    nokogiri (1.6.6.2)
      mini_portile (~> 0.6.0)
    ntlm-http (0.1.1)
    power_assert (0.2.4)
    rubyzip (1.1.7)
    simplecov (0.10.0)
      docile (~> 1.1.0)
      json (~> 1.8)
      simplecov-html (~> 0.10.0)
    simplecov-html (0.10.0)
    test-unit (3.1.3)
      power_assert
    trollop (2.1.2)
    unf (0.1.4)
      unf_ext
    unf_ext (0.0.7.1)
    webrobots (0.1.1)
    yajl-ruby (1.2.1)

PLATFORMS
  ruby

DEPENDENCIES
  creek
  faraday
  faraday_middleware
  json
  logger
  mechanize
  nokogiri
  simplecov
  test-unit
  trollop
  yajl-ruby

BUNDLED WITH
   1.10.6

bundle show --пути

/home/xyz/.rvm/gems/ruby-2.0.0-p643/gems/bundler-1.10.6/lib/gems/bundler-1.10.6
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/creek-1.0.8
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/docile-1.1.5
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/domain_name-0.5.24
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/faraday-0.9.1
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/faraday_middleware-0.10.0
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/http-cookie-1.0.2
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/json-1.8.3
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/logger-1.2.8
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/mechanize-2.7.3
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/mime-types-2.6.1
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/mini_portile-0.6.2
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/multipart-post-2.0.0
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/net-http-digest_auth-1.4
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/net-http-persistent-2.9.4
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/nokogiri-1.6.6.2
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/ntlm-http-0.1.1
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/power_assert-0.2.4
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/rubyzip-1.1.7
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/simplecov-0.10.0
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/simplecov-html-0.10.0
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/test-unit-3.1.3
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/trollop-2.1.2
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/unf-0.1.4
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/unf_ext-0.0.7.1
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/webrobots-0.1.1
/home/xyz/code/project/vendor/bundle/ruby/2.0.0/gems/yajl-ruby-1.2.1

проблема в моих файлах когда я пытаюсь использовать любой камень, скажем, simplecov его ошибка метания.

мой файл Ruby TestExample.rb

require 'rubygems'
require 'simplecov'
....
rest of the code
.....
enter code here

когда я пытаюсь запустить этот файл, это дает мне эту ошибку

/home/xyz/.rvm/rubies/ruby-2.0.0-p643/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:54:in `require': cannot load such file -- simplecov (LoadError)

Я что-то пропустил?? Может быть, как я требую файл неправильно?

1 ответов


не могли бы вы попробовать добавить эту строку в свой rb?

require 'bundler/setup'

а затем запустите его, делая

bundle exec ruby TestExample.rb

Я думаю, что это должно сработать для вас.