Почему я получаю конфликтующую кросс-версию в sbt в одной среде, но не в другой?

у меня есть проект sbt с этими зависимостями:

libraryDependencies ++= Seq(
  "org.scalatra"           %% "scalatra"          % ScalatraVersion,
  "org.scalatra"           %% "scalatra-scalate"  % ScalatraVersion,
  "org.scalatra"           %% "scalatra-specs2"   % ScalatraVersion   % "test",
  "ch.qos.logback"         %  "logback-classic"   % "1.1.2"           % "runtime",
  "org.eclipse.jetty"      %  "jetty-webapp"      % "9.1.5.v20140505" % "container",
  "org.eclipse.jetty"      %  "jetty-plus"        % "9.1.5.v20140505" % "container",
  "javax.servlet"          %  "javax.servlet-api" % "3.1.0",
  "org.sorm-framework"     %  "sorm"              % "0.3.18",
  "com.h2database"         %  "h2"                % "1.4.187",
  "org.fusesource.scalamd" %  "scalamd_2.10"      % "1.6"
)

на одной машине, я могу бежать ./СБТ без проблем; с другой стороны, я получаю

[error] Modules were resolved with conflicting cross-version suffixes in {file:/C:/dev/scalaspace/game-tracker/}game-tracker:
[error]    org.scala-lang.modules:scala-xml _2.11, _2.12.0-M1
[error]    org.scala-lang.modules:scala-parser-combinators _2.11, _2.12.0-M1

Я уже изолировал проблему и исправление. СОРМ зависит от компилятора 2.12.0-M1:

[info]   +-org.sorm-framework:sorm:0.3.18 [S]
[info]     +-com.github.nikita-volkov:embrace:0.1.4 [S]
[info]     | +-org.scala-lang:scala-compiler:2.12.0-M1 [S]
[info]     |   +-org.scala-lang.modules:scala-parser-combinators_2.12.0-M1:1.0.4 [S]
[info]     |   +-org.scala-lang.modules:scala-xml_2.12.0-M1:1.0.4 [S]
[info]     |   +-org.scala-lang:scala-reflect:2.11.0 [S] (evicted by: 2.11.6)
[info]     |   +-org.scala-lang:scala-reflect:2.11.6 [S]
[info]     |   +-org.scala-lang:scala-reflect:2.12.0-M1 (evicted by: 2.11.0)

Я могу сделать проект построить в обоих местах, добавив exclude("org.scala-lang","scala-compiler") к зависимости sorm. Но почему поведение непоследовательно? Обе среды используют одну и ту же версию sbt (0.13.8) и scala (2.11.6). Что изменилось?

1 ответов


учитывая pom для com.на GitHub.Никита-Волков: обнимемся!--7-->, Я предполагаю, что это связано с использованием диапазонов версий в сочетании с кэшированием:

<dependency>
  <groupId>org.scala-lang</groupId>
  <artifactId>scala-compiler</artifactId>
  <version>[2.10,3)</version>
  <scope>compile</scope>
</dependency>

особенно учитывая, что Scala 2.12.0-M1 был выпущен вчера:


чтобы исправить несоответствие, которое вы хотите очистить кэш плюща:

rm -r ~/.ivy2/cache

однако вы также хотите исправить версию scala-compiler используйте, и вы хотите, чтобы он соответствовал настроенному scalaVersion:

dependencyOverrides += "org.scala-lang" % "scala-compiler" % scalaVersion.value

Посмотреть подробнее переопределение версии раздел документов Управления библиотекой.