proguard-maven-плагин java 8

Я пытаюсь использовать Proguard, чтобы запутать мое приложение Java 8.

Proguard поддерживает Java 8 с версии 5.0

по какой-то причине программа-maven-plugin игнорирует мою конфигурацию для использования Proguard версии 5.1 и использует 4.3, несовместимый с Java 8.

Мои настройки

<plugin>
        <groupId>com.pyx4me</groupId>
        <artifactId>proguard-maven-plugin</artifactId>
    <version>2.0.4</version>
        <executions>
            <execution>
                <phase>package</phase>
                <goals>
                    <goal>proguard</goal>
                </goals>
            </execution>
        </executions>
        <configuration>
    <proguardVersion>5.1</proguardVersion>
    <obfuscate>true</obfuscate>
            <options>
                <option>-allowaccessmodification</option>
                <option>-keep class mypackage.Testt</option>
            </options>
            <libs>
                <lib>${java.home}/lib/rt.jar</lib>
        <lib>${java.home}/lib/javafx-mx.jar</lib>
            </libs>
        </configuration>
        <dependencies>
          <dependency>
            <groupId>net.sf.proguard</groupId>
            <artifactId>proguard-base</artifactId>
            <version>5.1</version>
            <scope>runtime</scope>
          </dependency>
        </dependencies>
  </plugin>

любой ключ?

Tks,

1 ответов


отвечая на мой собственный вопрос... Бывает, что Proguard версии 5.1 еще не доступен в репозиториях Maven. Необходимо вручную скачать его и запустить:

mvn install:install-file -Dfile=./proguard.jar -DgroupId=net.sf.proguard -DartifactId=proguard -Dversion=5.1 -Dpackaging=jar

кроме того, правильная конфигурация Proguard:

<dependency>
            <groupId>net.sf.proguard</groupId>
            <artifactId>proguard</artifactId>
            <version>5.1</version>
</dependency>